Registriere dich hier, um versteckte Bereiche sehen zu können, Highscores zu speichern oder Fragen zu stellen!

Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Einstellungen, Fragen und Antworten, das Hilfe-Forum für phpBB3 Foren von http://www.phpBB8.de und Forumo!
Kostenloses phpbb2 Forum
phpbb2 Forum Hosting
www.phpbb6.de
phpbb9 ist das Support Forum für unsere Hosting Services.Hilfe nur für Foren von Kostenloses-Forum.be, Userboard.org, plusBB, phpbb8.de, phpbb6.de, Gratis-Board.de und Forumo.de.
Du hast dein Forum nicht bei uns? Dann schaue dich um und siehe was du selbst völlig kostenlos machen könntest, gucke dir auch andere interessante Foren aus unserem Netzwerk an!
Du erhältst hier Tipps und Problemlösungen zu deinem Forum bei uns!

phpbb3
phpBB3 Forum Hosting
www.phpbb8.de
AbonnentenAbonnenten: 1
LesezeichenLesezeichen: 0
Zugriffe: 762

Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#1von karas » 02.11.2017 15:44

Hallo Community,

ich bin neuer Nutzer des PHPBB3 und mache mich nach und nach mit den Funktionen vertraut.
Beim FavIcon komme ich jedoch an meine Grenzen.
Ich konnte das originale FavIcon zwar löschen, aber kann kein neues hochladen.
Egal ob JPG oder GIF, egal ob 16x16px oder 32x32px, ich bekomme einen HTTP500 Fehler.
Gibt es derzeit ein bekanntes Problem mit dem Upload des FavIcon?
Alle anderen Grafik Uploads funktionieren nämlich soweit.

Über eine kurze Rückinfo oder Hilfe zu dem Thema wäre ich Dankbar.

PS. die Navigations Grafiken im Kästchen links oben (Portal, Forum, Mitglieder etc.) lassen sich noch immer nicht austauschen?
Der letzte Beitrag hier Forum dazu stammte von 2009 und ich konnte leider nichts aktuelles dazu finden.
Benutzeravatar
karas
Einsteiger
Einsteiger
 
Beiträge: 3
Registriert: 11.2017
Barvermögen: 388,12 Points
Danke gegeben: 0
Danke bekommen: 0x in 0 Post
Geschlecht: nicht angegeben
Deine Foren-URL: http://ggw.userboard.org
Forenstyle: subsilver Dark

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#2von GFriedrich » 02.11.2017 18:00

karas hat geschrieben:Hallo Community,

ich bin neuer Nutzer des PHPBB3 und mache mich nach und nach mit den Funktionen vertraut.
Beim FavIcon komme ich jedoch an meine Grenzen.
Ich konnte das originale FavIcon zwar löschen, aber kann kein neues hochladen.
Egal ob JPG oder GIF, egal ob 16x16px oder 32x32px, ich bekomme einen HTTP500 Fehler.
Gibt es derzeit ein bekanntes Problem mit dem Upload des FavIcon?
Alle anderen Grafik Uploads funktionieren nämlich soweit.

Über eine kurze Rückinfo oder Hilfe zu dem Thema wäre ich Dankbar.

PS. die Navigations Grafiken im Kästchen links oben (Portal, Forum, Mitglieder etc.) lassen sich noch immer nicht austauschen?
Der letzte Beitrag hier Forum dazu stammte von 2009 und ich konnte leider nichts aktuelles dazu finden.


Hallo, karas,
soweit ich das weiß ist der Name und die Endung Browserseitig vorgeschrieben, und lautet favicon.ico. Andere Endungen wie .jpg, .gif, oder.png werden nicht als favicon erkannt. Zudem sollte das favicon.ico im Rootverzeichnis des Forums liegen.

Gruß GF
Benutzeravatar
GFriedrich
Foren Mitglied
Foren Mitglied
 
Beiträge: 87
Registriert: 11.2009
Barvermögen: 731,56 Points
Bank: 0,00 Points
Danke gegeben: 0
Danke bekommen: 10x in 9 Posts
Geschlecht: männlich
Deine Foren-URL: https://coolcheffe.de/ccfo/   http://ccchat.de/

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#3von karas » 03.11.2017 14:21

Ich hätte nicht so schnell mit einer Antwort gerechnet, nachdem ich gesehen habe wie alt die Beiträge hier sind.
Das Problem ist das ich nur ein PNG, GIF oder JPG für das Favicon verwenden darf.

Favicon Upload

Lade hier ein GIF, PNG oder JPG File hoch um es als Icon in der Browserleiste für dein Forum zu verwenden.
Beachte bitte, das Bild darf maximal 38x38 Pixel und muss mindestens 12x12 Pixel groß sein.


Lade ich etwas anderes hoch, kommt eine entsprechende Fehlermeldung. Es funktioniert also nicht mit favicon.ico.
Lade ich aber ein passendes JPG oder GIF hoch gibt's n http500 Fehler.
Benutzeravatar
karas
Einsteiger
Einsteiger
 
Beiträge: 3
Registriert: 11.2017
Barvermögen: 388,12 Points
Danke gegeben: 0
Danke bekommen: 0x in 0 Post
Geschlecht: nicht angegeben
Deine Foren-URL: http://ggw.userboard.org
Forenstyle: subsilver Dark

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#4von GFriedrich » 03.11.2017 15:15

Hallo karas,
dann wurden die Kopfdaten in der entsprechenden Datei geändert, eventuell in der overall_header.tpl

Dazu ein Hinweis aus Wikepedia.

Einbindung in eine HTML-Seite

Es gibt heute zwei Möglichkeiten, ein Favicon in eine Seite einzubinden:

Hinterlegung unter dem festen Namen „favicon.ico“ im Basisverzeichnis der Domain, wie zum Beispiel bei https://de.wikipedia.org/favicon.ico. Dateien mit Namen favicon.ico in anderen Verzeichnissen werden von Browsern nicht beachtet. Hierbei sollten keine anderen Formate als das ico-Format verwendet werden. Zudem wird dies nicht von allen Browsern unterstützt und wird u. a. vom W3C ausdrücklich nicht empfohlen.
Referenzierung über ein HTML-Element, das in die Kopfdaten (<head>) einer HTML-Seite eingebunden wird. Laut HTML-Standard lautet die Bezeichnung hierfür icon,[1] der Internet Explorer benötigt jedoch die Bezeichnung shortcut icon. Hierbei können andere Formate als .ico verwendet werden.

<link rel="icon" href="/favicon.ico" type="image/x-icon">

Verwendet man XHTML statt HTML, so muss ein abschließender Schrägstrich am Ende des Tags stehen, da es sich hierbei um ein leeres XML-Element handelt. Zwingend benötigt wird dabei nur das href= Attribut; das type= Attribut empfiehlt sich, wenn andere Formate als .ico verwendet werden. Dabei müssen für folgende Formate folgende Codes verwendet werden:

Für ICO: image/x-icon, weniger verbreitet image/vnd.microsoft.icon[2]
Für GIF: image/gif
Für PNG: image/png[3]

Standardgrößen und Farbtiefen:

Für .ICO: 16×16 oder 32×32 und 16 bis 16,7 Millionen Farben
Für .GIF und .PNG: 16×16 und 256 Farben


Quelle: 
Benutzeravatar
GFriedrich
Foren Mitglied
Foren Mitglied
 
Beiträge: 87
Registriert: 11.2009
Barvermögen: 731,56 Points
Bank: 0,00 Points
Danke gegeben: 0
Danke bekommen: 10x in 9 Posts
Geschlecht: männlich
Deine Foren-URL: https://coolcheffe.de/ccfo/   http://ccchat.de/

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#5von karas » 06.11.2017 13:10

Oh super, das Favicon direkt im Template einbinden hat funktioniert.
Vielen Dank für den Tipp, das hat mir wirklich sehr weiter geholfen :thumbsup:
Benutzeravatar
karas
Einsteiger
Einsteiger
 
Beiträge: 3
Registriert: 11.2017
Barvermögen: 388,12 Points
Danke gegeben: 0
Danke bekommen: 0x in 0 Post
Geschlecht: nicht angegeben
Deine Foren-URL: http://ggw.userboard.org
Forenstyle: subsilver Dark

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#6von GFriedrich » 06.11.2017 15:30

karas hat geschrieben:Oh super, das Favicon direkt im Template einbinden hat funktioniert.
Vielen Dank für den Tipp, das hat mir wirklich sehr weiter geholfen :thumbsup:


Prima dass es nun geht :thumbsup:

Gruß GF
Benutzeravatar
GFriedrich
Foren Mitglied
Foren Mitglied
 
Beiträge: 87
Registriert: 11.2009
Barvermögen: 731,56 Points
Bank: 0,00 Points
Danke gegeben: 0
Danke bekommen: 10x in 9 Posts
Geschlecht: männlich
Deine Foren-URL: https://coolcheffe.de/ccfo/   http://ccchat.de/

Re: Favicon kann nicht hochgeladen werden - HTTP500 Fehler

Beitrag#7von Teamleiter & Techniker Gooof » 06.06.2018 23:16

Nun geht auch der Favicon Upload wieder, ein kleiner Fehler der zu einem Fatal Error geführt hat.
Code: Alles auswählen
return true;break;
break not in loop, durch return kommt es niemals zu dem break, wozu der Fatal Error :roll:
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
Benutzeravatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Beiträge: 30269
Registriert: 12.2005
Barvermögen: 3.962,31 Points
Bank: 27.117,30 Points
Wohnort: phpbb9.de
Danke gegeben: 1230
Danke bekommen: 3438x in 1917 Posts
Highscores: 208
Geschlecht: männlich
Deine Foren-URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth


Zurück zu "phpBB3: Hilfestellungen bei der Benutzung"


 

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 7 Gäste