Registriere dich hier, um versteckte Bereiche sehen zu können, Highscores zu speichern oder Fragen zu stellen!

Menübutton "Links" wird nicht markiert

Einstellungen, Fragen und Antworten, das Hilfe-Forum für phpBB3 Foren von http://www.phpBB8.de und Forumo!
Kostenloses phpbb2 Forum
phpbb2 Forum Hosting
www.phpbb6.de
phpbb9 ist das Support Forum für unsere Hosting Services.Hilfe nur für Foren von Kostenloses-Forum.be, Userboard.org, plusBB, phpbb8.de, phpbb6.de, Gratis-Board.de und Forumo.de.
Du hast dein Forum nicht bei uns? Dann schaue dich um und siehe was du selbst völlig kostenlos machen könntest, gucke dir auch andere interessante Foren aus unserem Netzwerk an!
Du erhältst hier Tipps und Problemlösungen zu deinem Forum bei uns!

phpbb3
phpBB3 Forum Hosting
www.phpbb8.de
AbonnentenAbonnenten: 1
LesezeichenLesezeichen: 0
Zugriffe: 438

Menübutton "Links" wird nicht markiert

Beitrag#1von Johnny spadix » 24.03.2016 19:27

Hallo zusammen :-)

Ich hatte mir kürzlich den MenüButton "Links" eingefügt. Nur wenn man ihn anklickt wird er nicht als geöffnet markiert. Aber dafür der MenüButton Downloads :-)

Bild

Dies ist mein Code:

Code: Alles auswählen
<li<!-- IF SCRIPT_NAME == 'Links' --> class="activetab"<!-- ENDIF -->><a href="http://scorpion.community/homepage/" title="Links"><span>Links</span></a></li>
Benutzeravatar
Johnny spadix
Foren Mitglied
Foren Mitglied
 
Beiträge: 106
Registriert: 11.2015
Barvermögen: 3.580,44 Points
Wohnort: RLP
Danke gegeben: 34
Danke bekommen: 7x in 6 Posts
Geschlecht: männlich
Forenstyle: prosilver Special SoftWood

Re: Menübutton "Links" wird nicht markiert

Beitrag#2von 4Cats » 24.03.2016 20:44

wie sieht denn die Seite aus wo die Links liegen?
Liebe Grüße Silke
Benutzeravatar
4Cats
Foren Benutzer
Foren Benutzer
 
Beiträge: 179
Registriert: 06.2011
Barvermögen: 10.495,02 Points
Danke gegeben: 51
Danke bekommen: 69x in 41 Posts
Geschlecht: nicht angegeben

Re: Menübutton "Links" wird nicht markiert

Beitrag#3von 4Cats » 24.03.2016 20:55

ok, ich versteh mal wieder etwas langsamer,
wenn du auf Links klickst, wird zwar die richtige Seite aufgerufen, aber in den Tabs wird Download angezeigt.
ist das jetzt richtig verstanden ?
Liebe Grüße Silke
Benutzeravatar
4Cats
Foren Benutzer
Foren Benutzer
 
Beiträge: 179
Registriert: 06.2011
Barvermögen: 10.495,02 Points
Danke gegeben: 51
Danke bekommen: 69x in 41 Posts
Geschlecht: nicht angegeben

Re: Menübutton "Links" wird nicht markiert

Beitrag#4von Johnny spadix » 24.03.2016 21:07

Ja genau :-)
Benutzeravatar
Johnny spadix
Foren Mitglied
Foren Mitglied
 
Beiträge: 106
Registriert: 11.2015
Barvermögen: 3.580,44 Points
Wohnort: RLP
Danke gegeben: 34
Danke bekommen: 7x in 6 Posts
Geschlecht: männlich
Forenstyle: prosilver Special SoftWood

Re: Menübutton "Links" wird nicht markiert

Beitrag#5von Teamleiter & Techniker Gooof » 27.03.2016 16:14

Ne, so geht das nicht.

Du müsstest, um die Markierung exakt bestimmen zu können, erstmal gucken was die Werte ausgeben.

Testen kann man das mit current script_name: {SCRIPT_NAME} und current query string: {FIRST_QUERY_STRING}.
Wenn man das irgendwo in einem Template einfügt, werden dort auf jeder Homepage Seite andere Werte angezeigt. (am besten in die Datei overall_footer.html)

Beispiel:
homepage/demo-scrollboxen.html
Code: Alles auswählen
current script_name: pages
current query string: p=demo-scrollboxen


Um den Link dann zu markieren am besten einfachsten nur den query string nehmen:
Code: Alles auswählen
<li<!-- IF FIRST_QUERY_STRING == 'p=demo-scrollboxen' --> class="activetab"<!-- ENDIF -->><a href="http://link.to/homepage/" title="Links"><span>Links</span></a></li>

oder (für andere Seiten im Forum wo das nicht so eindeutig ist auch den Script Namen):
Code: Alles auswählen
<li<!-- IF SCRIPT_NAME == 'pages' && FIRST_QUERY_STRING == 'p=demo-scrollboxen' --> class="activetab"<!-- ENDIF -->><a href="http://link.to/homepage/" title="Links"><span>Links</span></a></li>
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
Benutzeravatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Beiträge: 30245
Registriert: 12.2005
Barvermögen: 3.407,07 Points
Bank: 27.118,00 Points
Wohnort: phpbb9.de
Danke gegeben: 1228
Danke bekommen: 3422x in 1909 Posts
Highscores: 225
Geschlecht: männlich
Deine Foren-URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth

Re: Menübutton "Links" wird nicht markiert

Beitrag#6von Johnny spadix » 27.03.2016 19:41

Ich bin jetzt verwirrt :-)

Was soll ich genau machen?
Benutzeravatar
Johnny spadix
Foren Mitglied
Foren Mitglied
 
Beiträge: 106
Registriert: 11.2015
Barvermögen: 3.580,44 Points
Wohnort: RLP
Danke gegeben: 34
Danke bekommen: 7x in 6 Posts
Geschlecht: männlich
Forenstyle: prosilver Special SoftWood

Re: Menübutton "Links" wird nicht markiert

Beitrag#7von Johnny spadix » 17.06.2016 17:04

Hi :-)

Habe bisher keine Lösung gefunden...
Benutzeravatar
Johnny spadix
Foren Mitglied
Foren Mitglied
 
Beiträge: 106
Registriert: 11.2015
Barvermögen: 3.580,44 Points
Wohnort: RLP
Danke gegeben: 34
Danke bekommen: 7x in 6 Posts
Geschlecht: männlich
Forenstyle: prosilver Special SoftWood


Zurück zu "phpBB3: Hilfestellungen bei der Benutzung"


 

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste