Registriere dich hier, um versteckte Bereiche sehen zu können, Highscores zu speichern oder Fragen zu stellen!

Falsche Verlinkung

Nur fehlerhafte Funktionen, Datenbank Fehler (SQL), fehlende Funktionen die eigentlich eingebaut sind z.B. in anderen Styles oder Error-Meldungen.
Fragen wie was geht werden im Forum phpBB3: Hilfestellungen bei der Benutzung behandelt.
Kostenloses phpbb2 Forum
phpbb2 Forum Hosting
www.phpbb6.de
phpbb9 ist das Support Forum für unsere Hosting Services.Hilfe nur für Foren von Kostenloses-Forum.be, Userboard.org, plusBB, phpbb8.de, phpbb6.de, Gratis-Board.de und Forumo.de.
Du hast dein Forum nicht bei uns? Dann schaue dich um und siehe was du selbst völlig kostenlos machen könntest, gucke dir auch andere interessante Foren aus unserem Netzwerk an!
Du erhältst hier Tipps und Problemlösungen zu deinem Forum bei uns!

phpbb3
phpBB3 Forum Hosting
www.phpbb8.de
FollowersFollowers: 0
BookmarksBookmarks: 0
Views: 168

Falsche Verlinkung

Post#1by Ingola » 07.02.2009 14:37

Hallo Gooof,
ich hoffe das Thema ist richtig gewählt.

Folgendes Problem :
Wenn man sich in der Galerie befindet, kann man mit dem "Schwarzen Button" "Forum" nicht zurück.
Wenn man sich in der Galerie befindet erscheint bei betätigung des "Schwarzen Button" "Portal" die Fehlermeldung 404 URL nicht gefunden.

Im Persönlichen Bereich, Private Nachrichten geht derLink "Nach einem Mitglied suchen" nicht, das Feld bleibt leer.

Gruß Ingo
www.langbahn-forum.de Style Vista.
Forum URL http://www.langbahn-forum.de
Style Vista (geändert)
User avatar
Ingola
Foren Benutzer
Foren Benutzer
 
Posts: 150
Joined: 01.2009
Cash on hand: 0.00 Points
Location: 26190 Rastede
Thanks: 0
Thanked: 2 times in 2 posts
Gender: Male

Re: Falsche Verlinkung

Post#2by Teamleiter & Techniker Gooof » 07.02.2009 15:01

Müsste jetzt eigentlich richtig sein wenn du bei Styles -> Templates -> Vista -> Cache anklickst. Außer du hast das Template overall_header.html bearbeitet.
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
User avatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Posts: 30245
Joined: 12.2005
Cash on hand: 3,407.07 Points
Bank: 27,118.15 Points
Location: phpbb9.de
Thanks: 1228
Thanked: 3422 times in 1909 posts
Highscores: 226
Gender: Male
Your Forum URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth *

Re: Falsche Verlinkung

Post#3by Ingola » 07.02.2009 17:08

Hallo Gooof,
vielen Dank für die schnelle Lösung.
Ich habe mein overall_header geändert, aber das bekomme ich schon hin.

Das zweite Problem "Suche nach Mitgliedern" geht aber noch nicht oder ?

Gruß Ingo
Forum URL http://www.langbahn-forum.de
Style Vista (geändert)
User avatar
Ingola
Foren Benutzer
Foren Benutzer
 
Posts: 150
Joined: 01.2009
Cash on hand: 0.00 Points
Location: 26190 Rastede
Thanks: 0
Thanked: 2 times in 2 posts
Gender: Male

Re: Falsche Verlinkung

Post#4by Teamleiter & Techniker Gooof » 07.02.2009 18:46

dann suche in dem Template bitte:

Code: Select all
   <td align="left" valign="top" width="30%" id="linkbg">
<img src="{T_THEME_PATH}/images/spacer.gif" width="30" height="1" border="0" alt="" />
<a href="./portal.php" onmouseover="MouseOverRoutine('home')" onmouseout="MouseOutRoutine('home')"><img src="{T_IMAGESET_LANG_PATH}/button_home.gif" name="home" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="./index.php" onmouseover="MouseOverRoutine('forum')" onmouseout="MouseOutRoutine('forum')"><img src="{T_IMAGESET_LANG_PATH}/button_forum.gif" height="31" name="forum" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="{U_FAQ}" onmouseover="MouseOverRoutine('faq')" onmouseout="MouseOutRoutine('faq')"><img src="{T_IMAGESET_LANG_PATH}/button_faq.gif" height="31" name="faq" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="rules.php" onmouseover="MouseOverRoutine('rules')" onmouseout="MouseOutRoutine('rules')"><img src="{T_IMAGESET_LANG_PATH}/button_rules.gif" height="31" name="rules" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="memberlist.php?mode=leaders" onmouseover="MouseOverRoutine('contact')" onmouseout="MouseOutRoutine('contact')"><img src="{T_IMAGESET_LANG_PATH}/button_contact.gif" height="31" name="contact" border="0" alt="" /></a>
   </td>


und ersetze es mit folgendem:
Code: Select all
   <td align="left" valign="top" width="30%" id="linkbg">
<img src="{T_THEME_PATH}/images/spacer.gif" width="30" height="1" border="0" alt="" />
<a href="{U_PORTAL}" onmouseover="MouseOverRoutine('home')" onmouseout="MouseOutRoutine('home')"><img src="{T_IMAGESET_LANG_PATH}/button_home.gif" name="home" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="{U_INDEX}" onmouseover="MouseOverRoutine('forum')" onmouseout="MouseOutRoutine('forum')"><img src="{T_IMAGESET_LANG_PATH}/button_forum.gif" height="31" name="forum" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="{U_FAQ}" onmouseover="MouseOverRoutine('faq')" onmouseout="MouseOutRoutine('faq')"><img src="{T_IMAGESET_LANG_PATH}/button_faq.gif" height="31" name="faq" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="../rules.php" onmouseover="MouseOverRoutine('rules')" onmouseout="MouseOutRoutine('rules')"><img src="{T_IMAGESET_LANG_PATH}/button_rules.gif" height="31" name="rules" border="0" alt="" /></a>
<img src="{T_THEME_PATH}/images/div.gif" width="3" height="31" border="0" alt="" />
<a href="../memberlist.php?mode=leaders" onmouseover="MouseOverRoutine('contact')" onmouseout="MouseOutRoutine('contact')"><img src="{T_IMAGESET_LANG_PATH}/button_contact.gif" height="31" name="contact" border="0" alt="" /></a>
   </td>
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
User avatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Posts: 30245
Joined: 12.2005
Cash on hand: 3,407.07 Points
Bank: 27,118.15 Points
Location: phpbb9.de
Thanks: 1228
Thanked: 3422 times in 1909 posts
Highscores: 226
Gender: Male
Your Forum URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth *

Re: Falsche Verlinkung

Post#5by Ingola » 07.02.2009 21:07

Hallo Gooof,
die Änderung hat leider keine Wirkung.

Gruß Ingo
Forum URL http://www.langbahn-forum.de
Style Vista (geändert)
User avatar
Ingola
Foren Benutzer
Foren Benutzer
 
Posts: 150
Joined: 01.2009
Cash on hand: 0.00 Points
Location: 26190 Rastede
Thanks: 0
Thanked: 2 times in 2 posts
Gender: Male

Re: Falsche Verlinkung

Post#6by Teamleiter & Techniker Gooof » 09.02.2009 22:55

Aber klar, die Links sind dann richtig und geben keinen 404 Error mehr.
z.b. ./portal.php wird ersetzt mit {U_PORTAL}
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
User avatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Posts: 30245
Joined: 12.2005
Cash on hand: 3,407.07 Points
Bank: 27,118.15 Points
Location: phpbb9.de
Thanks: 1228
Thanked: 3422 times in 1909 posts
Highscores: 226
Gender: Male
Your Forum URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth *

Re: Falsche Verlinkung

Post#7by Ingola » 09.02.2009 23:09

Hallo Gooof,
nun haben wir aneinander vorbei geredet.
Die Verlingungen klappen, das ist in Ordnung.

Wenn ich im persönlichen Bereich bin, und auf Private Nachrichten senden gehe,
gibt es rechts ein kleines Fenster unter dem steht in Blau "Nach einem Mitglied suchen".
Aber dann geht kein Fenster auf.

Gruß Ingo
Forum URL http://www.langbahn-forum.de
Style Vista (geändert)
User avatar
Ingola
Foren Benutzer
Foren Benutzer
 
Posts: 150
Joined: 01.2009
Cash on hand: 0.00 Points
Location: 26190 Rastede
Thanks: 0
Thanked: 2 times in 2 posts
Gender: Male

Re: Falsche Verlinkung

Post#8by Lea » 10.02.2009 07:43

Hast du auch "PopUps" bei deinem Browser auf deiner Forenseite erlaubt?

Ansonsten: Welchen Browser benutzt du?
User avatar
Lea
Lebende Legende
Lebende Legende
 
Posts: 21204
Joined: 02.2016
Cash on hand: 250.00 Points
Thanks: 0
Thanked: 5 times in 1 post
Gender: None specified

Re: Falsche Verlinkung

Post#9by Ingola » 10.02.2009 08:34

Guten Morgen Lea,
sicherlich habe ich Popups erlaubt.
Im Adminbereich zbsp. Mitglieder verwalten, geht ja alles einwandfrei.

Als Browser benutze ich Firefox.

Gruß Ingo
Forum URL http://www.langbahn-forum.de
Style Vista (geändert)
User avatar
Ingola
Foren Benutzer
Foren Benutzer
 
Posts: 150
Joined: 01.2009
Cash on hand: 0.00 Points
Location: 26190 Rastede
Thanks: 0
Thanked: 2 times in 2 posts
Gender: Male

Re: Falsche Verlinkung

Post#10by Teamleiter & Techniker Gooof » 10.02.2009 22:39

Ist behoben bitte wieder Styles -> Templates -> Vista -> Cache

oder Styles -> Templates -> Vista -> Bearbeiten -> overall_header.html

suche:
Code: Select all
function find_username()
{
   <!-- IF UA_FIND_USERNAME -->
   window.open('{UA_FIND_USERNAME}', '_usersearch', 'height=500, resizable=yes, scrollbars=yes, width=740');
   <!-- ENDIF -->
   return false;
}

ersetzen mit:
Code: Select all
function find_username(url)
{
   popup(url, 760, 570, '_usersearch');
   return false;
}
Kostenloses phpBB3 Foren Hosting - Entwickler | Hosting | Admin :Pingouin02:
User avatar
Teamleiter & Techniker Gooof
Foren Doktor
Foren Doktor
 
Posts: 30245
Joined: 12.2005
Cash on hand: 3,407.07 Points
Bank: 27,118.15 Points
Location: phpbb9.de
Thanks: 1228
Thanked: 3422 times in 1909 posts
Highscores: 226
Gender: Male
Your Forum URL: http://support.phpbb8.de
Forenstyle: prosilver Special Smooth *


Return to "phpBB3: Fehlerhafte Funktionen & Bugs"


 

Who is online

Users browsing this forum: No registered users and 1 guest

Besucher kamen durch folgende Suchbegriffe auf diese Seite:

phpbb verlinkt nach login auf die falsche URL phpbb falsche verlinkungen falsche verlinkung bei phpbb php3bb nach anmeldung falsche url