Registriere dich hier, um versteckte Bereiche sehen zu können, Highscores zu speichern oder Fragen zu stellen!

Problem mit "new topic" Button

Adminbereich » Styles » Themes sind Stylesheets (CSS) Vorlagen (Farben, größen, Abstände (prosilver auch Grafiken))
Adminbereich » Styles » Templates sind HTML Vorlagen (wo was angezeigt wird und ob überhaupt)

subSilver und prosilver Styles - es gibt 2 Arten von Styles, hier alle im Überblick:
subSilver2 Styles: 610nm, AcidTech, Vista, bo2Soft, subsilver2, eTech, Serenity, vBoard, vLight, vPlasma, subBlack
prosilver Styles: BrownChocolate, WoWKing, Eliteblue, Glacier, GreenGrass, RedSunrise, prosilver
Kostenloses phpbb2 Forum
phpbb2 Forum Hosting
www.phpbb6.de
phpbb9 ist das Support Forum für unsere Hosting Services.Hilfe nur für Foren von Kostenloses-Forum.be, Userboard.org, plusBB, phpbb8.de, phpbb6.de, Gratis-Board.de und Forumo.de.
Du hast dein Forum nicht bei uns? Dann schaue dich um und siehe was du selbst völlig kostenlos machen könntest, gucke dir auch andere interessante Foren aus unserem Netzwerk an!
Du erhältst hier Tipps und Problemlösungen zu deinem Forum bei uns!

phpbb3
phpBB3 Forum Hosting
www.phpbb8.de
FollowersFollowers: 0
BookmarksBookmarks: 0
Views: 315

Problem mit "new topic" Button

Post#1by RC-Modellbauer » 20.12.2012 22:17

Hallo ich habe mir für mein Forum einen neuen "New Topic" Button gebastelt.

Diesen habe ich dann als png. Datei gespeichert und in meinem Forum hochgeladen.
Danach bin ich auf Styles/Grafiksammlung gegangen
und habe dort dann den neuen Button bei "Neues Thema erstellen [en]" ersetzt.

Nun sieht das ganze so aus :

Image

Wie man sieht schaut am linken Rand des neuen Buttons ein Link herraus.

Wenn man jetzt mit der Maus auf den neuen Button geht rutscht der ganz Button nach unten und der dahinter liegende Link (Post Topic) ist komplett zusehen.

Image

Was kann ich machen damit der neue Button stehen bleibt und nicht verrutscht wenn man mit der Maus drauf geht?
Und wie bekomme ich den Link (Post Topic) dahinter weg?
Image
User avatar
RC-Modellbauer
Foren Mitglied
Foren Mitglied
 
Posts: 103
Joined: 12.2011
Cash on hand: 5,002.03 Points
Thanks: 50
Thanked: 10 times in 7 posts
Highscores: 1
Gender: Male
Forenstyle: AeroBlack

Re: Problem mit "new topic" Button

Post#2by tups » 20.12.2012 23:13

ACP-->Styles-->Themes-->dein Style bearbeiten
suche nach
Code: Select all
.buttons div a:hover span   { background-position: 0 100%; }


ersetze es mit
Code: Select all
.buttons div a:hover span   { background-position: 0 0; }


Damit hört das Springen des Button auf, allerdings hast du dann auch bei den anderen Button keinen Hovereffekt, z.B. bei Antworten.... usw. Aber ich schätze mal das du eh alle Button austauschen willst.

Um jetzt den Text hinter dem Button zu entfernen
ACP-->Styles-->Templates-->dein Style bearbeiten
öffne viewforum_body.html
suche und lösche folgende 2 Wörter
Code: Select all
Post Topic

Die gibt es 2 mal in dem Template. Du musst natürlich beide Löschen, aber jeweils nur diese beiden Wörter.
Image
User avatar
tups
Supporter im Ruhestand
Supporter im Ruhestand
 
Posts: 7019
Joined: 06.2009
Cash on hand: 100,578.29 Points
Bank: 125,443.10 Points
Thanks: 561
Thanked: 1770 times in 1468 posts
Gender: Male

The following user would like to thank tups for this post

Re: Problem mit "new topic" Button

Post#3by RC-Modellbauer » 20.12.2012 23:29

tups wrote: Aber ich schätze mal das du eh alle Button austauschen willst.


Ja genau.

Vielen Dank für deine schnelle Hilfe!
Hat super funktioniert.
Ich hoffe ich bekomme das mit den Antwort Buttons usw. selber hin.
Image
User avatar
RC-Modellbauer
Foren Mitglied
Foren Mitglied
 
Posts: 103
Joined: 12.2011
Cash on hand: 5,002.03 Points
Thanks: 50
Thanked: 10 times in 7 posts
Highscores: 1
Gender: Male
Forenstyle: AeroBlack


Return to "phpBB3: Styles, Themes und Templates"


 

Who is online

Users browsing this forum: No registered users and 1 guest

Besucher kamen durch folgende Suchbegriffe auf diese Seite:

phpbb neues thema button position